WordPress更新出现SSL certificate problem的解决方法

WordPress的版本更新每次都会带了很多功能和安全性方面的扩展增强,所以,WPPOP也是强烈建议用户及时更新WordPress版本到最新版,从而保证网站的安全稳定运行,有用户反应在更新WordPress时,会碰到“SSL certificate problem”错误,下载失败,无法在后台直接完成WordPress更新,在安装/升级WordPress主题、插件时,也可能会出现类似错误提示:

下载失败。: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

这个错误原因可能是由于网站所在空间的 php 的 curl 版本过旧导致的。

解决方法1

在当前主题的 function.php 文件中,加入以下代码:

add_action('http_request_args', 'wppop_http_request_args', 10, 2);
function wppop_http_request_args($args, $url) {
$args['sslverify'] = false;
return $args;
}

解决方法2

下载安装插件后,启用即可解决。

GitHub下载链接: https://github.com/pronamic/wp-http-curl-transport-last/archive/develop.zip

上一篇:

下一篇:

在线留言

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

官方微信

微信扫一扫 关注我们

返回顶部